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You can perform round-trip engineering in NetBeans, to keep Java source code and class model in
sync. In this tutorial, we will see how to create a class model in NetBeans and eventually generating

source code from model.

1.

Create a Java project Express Courier in NetBeans.

O Mew Java Application

Steps

Name and Location

1. Choose Project
2. Name and Location

Project Name: Express Courier

Project Location: | C:\Users\Peter\Documents\NetBeansProjects Browse...
Praoject Folder: C:\Users\Peter \Documents\NetBeansProjects\Express Courier
[] Use Dedicated Folder for Storing Libraries
Libraries Folder: Browse...
Different users and projects can share the same compilation
libraries {see Help for details).
Create Main Class | express.courier.ExpressCourier
< Back Next = Cancel Help
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2. Right-click on the project node in Projects window and select Open Visual Paradigm from the

popup menu.
Projects X | Files Services
: New >
Build
um— *
History H

[*%  Open Visual Paradigm L\\)
B Close Visual Paradigm

77 Update UML Madel
€ Visual Paradigm H

Properties

3.  You may be prompted to specify the location of your Visual Paradigm project. In this case,
simply select Create in default path and click OK to proceed.

@ Project Structure X

Q Please select the Visual Paradigm project path.
A4

() Create or select existing project at external location

Path: [NetBeansProjects\Express Courier \wpproject\Express Courier.vpp

Remember my decision
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4. In Diagram Navigator, right-click on Class Diagram and select New Class Diagram from the

popup menu.

Projects |Files | Services |Dia.. X |Class ... |Model |Logica...

E-Bi-o-B-2-

BExpress Courier
L‘—J: UML Diagrams
g Use Case Diagram

ass Diagram|
Sequence [ |%| New Class Diagram N

Mew Diagram...

- [EE] Activity Did #2 Sort Class Diagram by name

~[E] Component E\ Collapse
- [7 Deploymen
-

Expand

g Composite Structure Diagram
~[[1| Timing Diagram
----Interactinn Owerview Diagram

Requirements Capturing

Database Modeling

Business Modeling

SysML

P =T = =

5. A new diagram is created. You asked to enter a package header on top of the diagram. Enter

myapp and press Enter.

Start Page X|@Expresst:ourier.java X||—41 Class Diagraml X

[~ 2 &[5 A [mraee
- N

(\' Tools ==

0 Point Eraser

|i Sweeper

6. You are asked to provide the diagram name. Enter Domain Model and press Enter.

StartPage X | @ ExpressCourier.java | I_Aj myapp X|

W i @E‘I myapp| o

Diagram name Domain Mode| |

: s

;\‘ Tools ==

. Point Eraser

|i Sweeper
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7.  Click on the down arrow button near the shape selection Class in diagram toolbar, and select
Interface.

ﬁ Class -

| Inkerface (1) %J

Enumeration (¥)

| 1 Class L |

Primitive

P ORM-Persistable Class (Shift+A)
% ORM-Abstract-Persistable Class (L)
Y% ORM-User-Type Class (Shift+2)
T DRM-Parameterized-Type Class (P)

@ Entity Bean
] REST Resource ‘ |

% Mote

8.  Click on the diagram to create an interface class and name it as IMailDelivery.

=< |ntarface>>

9. Create operations in IMailDelivery. Right-click on the class IMailDelivery and select Add >
Operation from the popup menu.

I Moy
-— Add J Attribute Alt+5Shift+A
a Open Specification... Enter Attribute with Getter and Setter
Stereotypes 1 Operation L\\, Alt+5hift+0
Model Element Properties 1 Constructor
Sub Diagrams 3 Template Parameter
Create Parent »

10. Enter setState(state : char) : void to create a public operation stateState with parameter state
and return void.

]
<<|nterface==
m IMailDelivery g
+zetState(state:char)vo id|

11. Press Enter to create another operation. Name it printShipmentinfo() : void. Click on diagram to
confirm editing.
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12. We need to create a class for local delivery which inherits IMailDelivery. Move the mouse pointer
over interface IMailDelivery, press on the Resource Catalog icon and drag downwards.

e

<<|nterface>> 2 I} \\

IMailD Y 1
+setState(state : char) : void *
‘j‘llintﬂimlnfl)(} : woid na

13. Release the mouse button. Select Realization -> Class in Resource Catalog.

<<Interface>>
IMailD y

+satStatejstate : char) : void

+printShipmentinfo() : void

\
t\iv
\i*‘ﬁ
N

=

u
%
m

P o
W"' ¢ o

Realization -> Class

14. Name the class LocalDelivery and press Enter to confirm.

<<Interface>>
IMailDelivery

+setState(state : char) : void

+printShipmentinfol) : void

A

LocalDelivery
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15. Asthe LocalDelivery class is implementing the interface IMailDelivery, we need to implement
the operations defined in IMailDelivery. Right-click on class LocalDelivery and select Related
Element > Realize all Interfaces from the popup menu.

<<Interface>>
IMailDelivery

+setState(state : char) : void

+printShipmentinfo() : void

A
[
|
l
l
[ a -
(B Aty
n Add >
- a Open Specification... Enter
Steregtypes
T l ) Transit to New Model Element...
Grouping ]

Realize all Interfaces
Styles and Formatting o I/\\,
Show Associations
Presentation Options

Analysis..
Layer ] Merge
Define Design Pattern... Merge from Other Model Element(s)...
Related Elements 3 Merge to Model Element...

16. You can see that operations setState and printShipmentinfo are both inherited.

<<Interface>>
IMailDelivery

+setState(state : char) : void

+printShipmentlnfol) : void

A

LocalDelivery
+getState(state : char) : void
+printShipmentinfo() : void

17. Itistime to add attributes to classes. Right-click on class LocalDelivery and select Add >
Attribute from the popup menu.

18. Enter state : char to name the attribute as state, and set the type as char.

b
Local -very
-state:chari
+setState(state : char) : void
+printShipmentinfo() : void

19. Press Enter to proceed to the next attribute. Enter postage : double as attribute name and type.
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20. Again, press Enter and create attribute shipmentNum : int.

<<Interface>>
IMailDelivery

+satState(state : char) : void

+printShipmentlnfo() : void

A

LocalDelivery
-state : char
-postage : double
~shipmentMum : int
+setState(state : char) : void
+printShipmentinfo() . void

21. We need to have two constants for representing states. Press Enter to continue creating
attribute. Name the attribute STATE_INIT : char = 'a’. This means to create an attribute named
STATE_INIT, which is in char type and have 'a’ as default value. Press Enter to create another
constant STATE_DELIVERED : char ='b'. Up to now, the class should look like:

<<Interface>>
IMailD y

+setState(state : char) : void

+printShipmentlnfol) : void

A

LocalDelivery
-state : char
-postage : double
-shipmentMum : int
-STATE_INIT : char ="a’
-STATE_DELIVERED : char = b
+satState(state : char) : void
+printShipmentinfol) : void

22. In order to declare both STATE_ attribute as constants, select STATE_INIT, press the Ctrl key
and select STATE_DELIVERED to make a multiple selection. Right-click on them and select
Model Element Propertes > Scope > classifier from the popup menu. By doing so, both
attributes will be static (in code level) and are underlined.

+setState(state : char) : a Open Specification... Enter

intShipmentinfol) : w
.‘p“ oh: v Stereotypes

Model Element Properties

Mew Attribute Alt+5Shift+A
Mew Operation Alt+5hift+0
Create Getter and Setter
Sub Diagrams

ﬂ Delete
Duplicate Ctrl+E
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23. Again, right-click on the two attributes and select Code Detail > final from the popup menu.
Click on the diagram to confirm editing. The class should now become:

LocalDelivery
-state : char
-postage : double
-shipmenthum : int
-STATE_IMIT : char ="a’
-STATE DELIVERED : char = '

+setState(state : char) @ void
+printShipmentinfo() : void

24. We need to create a new class Mail with association from class LocalDelivery. Move the mouse
pointer to the class LocalDelivery. Press on the Resource Catalog icon and drag it out.

! P """~
LocalDelivery 4 %
-state : char

-postage : double
-shipmentMum : int
-STATE_INIT : char ='a’
-STATE_DELIVERED : char =

+setState(state : char) : void
‘;lintﬂipmamlnfo[} *woid n

25. Select Aggregation -> Class in Resource Catalog.

LocalDelivery
-state : char
-postage : double
~shipmentum : int v
-STATE_INIT : char ='a’ -
-STATE _DELIVERED : char = b

+zetState(state : char) : void
+printShipmentinfof) : void

Sl
[ { mi<
B o«

o

P ¢ o

Aggregation -> Class
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26. Drag to the right of the class LocalDelivery and release the mouse button. Name the new class
Mail.

<<|nterface>>

IMailD Y
+setState(state : char) : void
+printShipmentinfo() : void

A

LocalDelivery
-state : char
-postage : double
-shipmentMum : int Mail
-STATE_INIT : char ='s" Ko———
-STATE_DELIVERED : char = b’
[+setState(state : char) : void
+printShipmentinfo() : void

27. Follow the previous steps to create attributes in class Mail.

Clasq Attributes Operations

Mail | fromPerson : String -
fromContact : String
toPerson : String
toContact : String
mailType : int

28. We need to describe the attribute mailType by listing the possible values. Select mailType.

29. Activate the Description pane. If you cannot find it on the screen, or if you had closed that,
open it via the View menu. In the Description pane, enter the following:

Possible types:

1 - Flat

2 - Letter

3 - Postcard

4 - Parcel

Domain Model X = X|Diag_.. |Prop...|StenciI|0RM |Tea... | =
B~ +r=~F-B-F F > (

<<Interface=>> Possible types:
IMailDelivery 1- Flat
+setState(state | char) @ void 2 - Lefter
[+printShipmentinfo() : void 3 - Postcard
& 4 - Parcel

LocalDelivery
-state : char
-postage : double
-ghipmentMum : int
-STATE_INIT : char ='a’
-STATE_DELIVERED : char = b’
+setState(state : char) @ void
+printShipmentinfo() : void
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The description for classes, attributes, operations and parameters will become comments in

source code to be generated.

30. Up to now, the diagram should look like:

<<|nterface=>>

IMailDelivery
+setState(state : char) : void
+printShipmentinfol) : void

|

[

[

|

|

LocalDelivery

-state : char Mail
-postage : double -fromPerson : String
~shipmentMum : int -fromCaontact : String
-STATE_INIT : char ='a’ > -toPerson : String
-STATE _DELIVERED : char = b -toContact : String
+setState(state : char) : void -mailType : int
+printShipmentinfa(} : void [

31. Save your work via the File menu.

32. Now comes the code generation. Select the menu Update Code on Diagram Navigator.

l.ifl---I UML Diagrams
-.[i7|Use Case Diagri
= Class Diagram (1)

L [pomain Model

&1 Sequence Diagram

| Communication Diagram

77 Update UML Model Element

_i|5tate Machine Diagram
- |Activity Diagram
Component Diagram

| Deployment Diagram
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33. Check the Projects window. You should see a list of generated file. You can open them to fill in

the code body.

1) Express Courier - NetBeans IDE 8.1 - o x
File Edit View Mavigate Scurce Format Modeling Refactor Rum Debug Profile Tesm Took Window Help (G Search (Cnl+f
abal L et YT PRG-I MNE GRS G EOILOOREC
| Files | Déa... | Cha... — || saartPage || ExpressCounerjava % || Domantodel 3¢ [ Maljava X * O [pes... % | Prop..|Stencil OAM | Tea.. =
'9‘“’““"‘:“’ Somce | ooy | B-E-C TSRO IFEeB (AU 0EH O H 6 e 8 a s .
B Source Pacag 1 package myappr A m
=[] exress.couter 2 = ===
B ExremCouier java o @ ;#—::
= [ = al | -
[ psDerery.jove g i
5 LocalDedvery. java M
[ = =
i [ Lbraries ; =)
3 L
10 public class Mail {
i
12 private String
13 privace String
14 pEa:
15 privace
16 Brivace i bt
¥ *
Mavigator X = |[E rocsneiveryjova x| =)
[ = T |[suwe ooy B B-8-ATFRO|FPELE A0 0 0 L
= LocaDelvery i Maehver 1 package myspp: A
@ erntshementinfal) 2
O setfatehe Hate) 3 public #lass LecalDelivery isplements IMailDelivery |
) STATE_DELIVERED : cha "
Ry sTATE I s s private char st
8 postage : doutle ¢ .
8§ shomenttium 7
B state : cho & .
3 -
1
1 E
12
13 - r state
== - = B < >
& 068 ® s [ s > ®
& (1) Notscaniors () Message 1) 1 »

34. This is the end of the tutorial. Instead of closing NetBeans now, you may try something more
by editing the code like to add, rename or delete class, attributes and operations, and click the
Update UML Model button on toolbar, and observe the changes that will make in the class

model. Enjoy!

Related Links
. Tutorial - Working with Hibernate in NetBeans

. Tutorial - Perform UML Modeling in NetBeans

. User's Guide - NetBeans Integration
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