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Eclipse is truly one of the best integrated development environment (IDE). To many software
developers, Eclipse was the first IDE they ever used for serious software development. Eclipse
is easy to use, and it comes with a lot of useful features to make implementation faster and more
accurate, ultimately improving efficiency and software stability.

Visual Paradigm is an agile development platform that provides software developers with the wide
variety of toolset they need for designing great software products. It supports a collection of widely-
used modeling notations, such as UML, ERD and BPMN and more. Software developers can either
run Visual Paradigm in standalone manner, or to run it in embedded extension within the IDE. With
this Eclipse UML tool, developers can perform visual modeling and other agile development activities
within a unified Eclipse IDE platform.

In this tutorial, you will walk through the steps required to integrate Visual Paradigm with Eclipse. The
second part of the tutorial will demonstrate the automatic generation of Java code from UML class
diagram.

Preparation

In order to follow this tutorial, you must have Visual Paradigm installed, which can be downloaded
from Visual Paradigm download page. Besides, you also need the Eclipse platform, which can
downloaded at the Eclipse official site.

Installing Visual Paradigm in Eclipse
1. InVisual Paradigm, select Window > Integration > IDE Integration... from the application

toolbar.
untitled - Visual Paradigm

Team Tools Modeling | Window | Help
Application Options
[~ Project Options u

Configuration | Integration
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Shape Editor
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2. Inthe Visual Paradigm IDE Integration window, check Eclipse Integration.

Select Products
Select the products you are going to install.

Y

Visual Paradigm 13.0 ¢

Perform business process modeling (BPMN), UML modeling, use case
management and database design (ERD) in your favorite IDE, thanks to the
seamless integration with the following IDEs.

li Eclipse Integration

[_] NetBeans Integration
[] IntelliJ IDEA / Android Studio Integration

[[] Visual Studio Integration

Visual Paradigm Visual Studio Integration can only be installed by the user
with Computer administrator account

cone

3. Click Next.

4.  Enter the path of Eclipse and click Next.

IDE Configuration
Specify the installation directory of IDE(s).

Visual Paradigm 13.0 Eclipse Integration
< eclipse

Eclipse Directory

Install in existing Eclipse

Directory: |C\Wsers\Petereclips e\java-marsieclipse

Tutorial

This begins files copying. If you see the error messages "java.io.lOException: Cannot make dirs
for file...", please restart Visual Paradigm with the Run as Administrator option. When finished
files copying, close Visual Paradigm and move on to the next section to see how to create a

Java project in Eclipse along with UML model.
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Creating a Java Project
1. Start Eclipse.

2.  Select File > New > Java Project from the main menu to open the New Java Project window.

3. Inthe New Java Project window, enter My Project in the Project name field.

Create a Java Project g
Create a Java project in the workspace or in an external location.

Project name: | My Project] |

Use default location

Location: | Chworkspace\My Project Browse...

4. Click Finish.

Creating a UML Model for the Java Project
Now, you have an empty Java project. Let's create a UML model for it. To create a UML model:

1. Right-click on the project node in Package Explorer and select Open Visual Paradigm from
the popup menu.

[# Package Explarer 2 = | ¢ ~ — 0

= EMyProj ct
New >i

Go Into

T Es Alt+Enter

Open Visual Paradigm
o1 Update UML Model
i Select In Maodel [

&7

I Select In Diagram...

Visual Paradigm Project 3

2. Ifyou see the VM Requirement dialog box, please keep the option Configure "eclipse.ini"
and restart eclipse selected and click OK to restart Eclipse, and then re-perform the previous
step to open Visual Paradigm.

The current VM argument sun.javald.d3d has not set to FALSE yet. We recommend
you to turn off sun.java2d.d3d, otherwise Visual Paradigm may not be able to run
properly, Would you like to start Visual Paradigm with the current setting?

Perform

(®) Configure "eclipse.ini” and restart eclipse
() Start anyway
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3.

Click OK when you are prompted to select a path to store the .vpp file.

@ Flease select the Visual Paradigm project path.

() Create or select existing project at external location

Path: IC: workspace\My Project\vpprojectiMy Project.vpp

Remember my decision

UML Modeling in Eclipse
Let's draw a simple class diagram. We will generate Java code from it in the next section.

1.

2.

https://lwww.visual-paradigm.com/tutorials/eclipseuml.jsp
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Tutorial

In Diagram Navigator, right-click on Class Diagram node and select New Class Diagram from
the popup menu.

A new diagram is created. Double click on the package header field at the top left corner of the
diagram, with a labeled <default package> in it.
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3. Enter myapp and press Enter. From now on classes to be drawn in this diagram will be placed
in a (new) package named myapp. In practice you can also enter a nested package structure
like com.vp.myapp.

| Class Diagram1 53
9

[~ & ®[s A [mveeel

A
;9\‘ Tools == I"\’

. Paink Eraser

|i Sweeper

4.  Create a class. Select Class from the diagram toolbar. Drag it out and put it onto the diagram.
Enter User as name and press Enter to confirm.

[~ 2 &[S Al [mvaee|a
¥

;\ Tools =L

4 Point Eraser -
i Usel

> Magnet L\)

/ Gesture Pen

|j Class =L ’

'CIass ~-' "’

<+ Generalization  ~

U2 Usage
= Association =
<» N-ary Association

& Association Class

-3 Nenendency -

5. A user has two attributes: name and phone number. Let's add them. Right-click on the User
class and select Add > Attribute from the popup menu.

Attribute k Alt+5hift+A

v E Open Specification... Attribute with Getter and Setter
Stereotypes ¥ Operation Alt+Shift+Q
Model Element Properties > Constructar
Sub Diagrams L4 Template Parameter
Create Parent 3

6. Enter name : String to create the name attribute in String type. Then press Enter to confirm.
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7.  Similarly, enter phoneNum : int to create the phoneNum attribute in int type. Then press Enter to
confirm it and press Esc to cancel the next attribute.

User
-name ! String
-phoneNum : int

8. We want Visual Paradigm to generate getter and setter for the attributes during code generation.
Right-click on the name attribute and select Create Getter and Setter from the popup menu.

name ! S
-phoneNu E Open Specification... Enter

Stereotypes 3
Model Element Properties 3
Mew Attribute Alt+Shift+A
Mew Operation Alt+5Shift+0

Create Getter and Setter k
Sub Diagrams 3

9. Repeat the previous step on the attribute phoneNum. Up to now, your class diagram should look
like this:

-name : String

-phoneMum : int

+gethame(): String

+setName(name : String) : void
+getPhone Numi) : int
+zetPhoneNum(phoneMum ! int) : void

Generate Java Code from UML Class
Let's produce Java source code from the UML class. There are several ways to achieve this. Here

let's try the one that generate code for the entire UML model. Click on the Update Code button at the
top of Diagram Navigator.

o= gm Bp > = 8 | [B*myapp &
E=LN y
BE-Bl-a-B-2@ [r4Y[s Al [vmxls
= —7UML Diagrams T Update Code

- [E5]Use Case Diagram 29 |jpgate UML Model Element

- = Class Diagram (1) F o

| -1myapp & Point Eraser
- 7| Sequence Diagram 1 )
- [§=] Communiication Diagram A

- [E7]State Machine Diagram ©> Magnet
= Activity Diagram
. i Component Diagram .
" | Deployment Diagram | 1 Class

- [i|Package Diagram Bl class =
. [F5| Object Diagram

# Gesture Pen

< Generalization +

In the Package Explorer, expand the project node and the src folder node. The package myapp and

User class are there. Open User.java. You can see the User class filled with attributes and its getter
and setter.
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BB @M BErz ™ = 8 @‘myapp [J] Userjava &2

%| e v ; package myapp;
3 public class User {

4 =) My Project

4 [ src 1
a 3 myapp 5 private String name;
I m Userjava [ private int phoneNum;
' cE 7
E giRE ?:.::tm bibrary [J2v25E-14] 82 public String getName() {
Ppre) 9 return this.name;
10 1
11
122 public void setName(String names) {
13 this.name = name;
14 1
15
162 public int getPhoneNum() {
17 return this.phoneNum;
18 1
19
202 public void setPhoneNum{int phonelum) {
21 this.phoneNum = phonelum;
22 1
23
24 |]

Perform Coding
In this section, you are going to build an executable application with the User class.

1. Create a Main class. In the Package Explorer, right-click on the package myapp and select
New > Class from the popup menu.

2. In the New Java Class window, enter Main as class name and click Finish.

Java Class @
Create a new Java class.

Source folder | My Project/src | | Browse... |
[JEnclosing type: Browse...
Name: | Mainl |
Modifiers: (®) public () package private protected

[ abstract [|final static
Superclass: | javalang.Object | | Browse...
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3. Create a static main method in the Main class that create and instantiate two User objects. Set
the name and phone number through the setter.

[ "myapp

[7] Userjava [ Mainjava &2
1 package myapp;
2

3 public class Main {

4

=
3
7
8
9
2
1
2

public static void main(String[] args) {

User ul = new User();
ul.setName("Peter”);
ul.setPhoneNum(laaeaa) ;

User u2 = new User();
u2.setName( "Mary™);
u2.setPhoneNum(2@aeaa) ;

bl

4. It would be nice to add into the User class a method to print out its name and phone number.
Add a public method printinfo() in the User class.

) "myapp

Userjava &2 Main.java
[ User; [J] Main;

1 package myapp;

2

3 public class User {

private String name;
private int phoneNum;

public String getName() {
return this.name;

}

public void setName(String name) {

this.name = name;

}

public int getPhoneNum() {
return this.phoneNum;

}

public void setPhoneNum{imnt phonelum) {

this.phoneNum = phonelum;

}

public void printInfo(){
System.owt.println("Name:

}

+ name +

. Phone num:

+ phonelium) ;|
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5.  Call printinfo() from the Main class to display the information of created users.

&) *myapp [J] Userjava [ Mainjava &2
package myapp;

2
3

public class Main {

public static void main(String[] args) {
User ul = new User();
ul.setName("Peter"};
ul.setPhoneNum(leaeaa) ;

User u2 = new User();
u.setName( "Mary");
u2.setPhoneNum(280888@) ;

ul.printInfo();
u2.printInfo();|

Running the Application
Let's run the application. Keep the Main class opened. Select Run > Run As > Java Application
from the main menu. You should see the Console view appear with users' information printed in it.

[ Message B Console 2 | K %| =X | ) i~ = 0
<terminated> Main [Java Application] C:\Program Files\Java'jre1.8.0_51\bin\javaw.exe (Mar 3, 2016, 11:55:08 AM)

hame: Peter. Phone num: 1@@@e@
Name: Mary. Phone num: 2806080

Updating the UML Model from Java Code

You have made some changes in source code, such as the creation of Main class and printinfo() in
User class. In order to keep the design consistent with your source code, you need to update the UML
model from code. Let's do it now.

1. Inthe Eclipse toolbar, click on the Update UML Model button.

Help

ARG CRER AR e\ Hee= IRy
Update UML Model pecess |1:| 5| {

2. Open the class diagram. The printinfo() method is presented in the User class.

-name ! String

-phoneNum : int

+getName(): String

+getPhone Numi) : int
+setPhoneNum{phoneNum : int) : void
+setName(name : String) : void
[+printinfo(} : void
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3.  For the Main class, you can find it under the Model Explorer. Drag it out and put it below the

User class.

[Fo|Emum|Eer =
o-B-#-4-@-2

= B8 @*myapp ot Us

[:_JMy Project™
E!--E.myapp

j myapp

i Main =ty

-- i User \

Related Links

--» Dependency -

“82 Abstraction -

. Tutorial - Hibernate in Eclipse

. Tutorial - C# Round-trip engineering

[ & ®[s A [mvaee|a
v
y\‘ Tools =L
& Point Eraser
Ii Sweeper i
€ Magnet -name : String
\ / Gesture Pen -pl:r:;:n}: int
+g : Btring
\ [] Class = +getPhone Num) : int
. +satPhoneNumiphoneNum : int) : void
\ i Cles M +setName(name : String) : void
\bd— Generalization = +printinfo(} : void
%&age
C nsscmi“ -
— El Main =
<> N-ary Association . — + 4;11 = 5\1’0*':'"
& Association Class w w .
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