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Business Process Modeling Notation 2.0 makes a great improvement in business process modeling.
There are number of new notations introduced in BPMN 2.0. In this tutorial, we will show you how

to draw choreography task and message. We will draw the example diagram of BPMN 2.0 draft
specification (An example of stand-alone Choreography diagram). By finishing this tutorial, you will be
able to draw a business process diagram that looks like this:
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Drawing a BPMN 2.0 business process diagram
1. Create a new project by selecting Project > New from the application toolbar. In the New
Project window, enter Tutorial as project name and click Create Blank Project.

2.  Let's create a model first. Select View > Project Browser from the application toolbar.
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3. Open the Model Structure page in Project Browser

Diagrams Model Struct e My Recent Team Recent

4.  Click on the New Model button on top of the model list on the left hand side.

Ml Tutorial

-ew Model

5. Name the model Sales and click OK to confirm.

References Project Management I Quality I Comments ﬁ
Taooed Values Constraints I Diagrams I Traceability
General | Children I Relations I Chart Relations I Stereotypes. ‘
Name:|5ales |
Description:

6. We can create pools directly under Sales model without using diagram. Let's try. Right-click on

Sales model and select Model Element > New Model Element... from the popup menu.
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7.  You can search the model you would like to create in the New Model Element window. Enter

Po in the Model element type text field to search for Pool.

Model element type :
Model element name :

Open specification after create

8. Enter Customer as Model element name.

Model element type : |Pool

Model element name : | Customer

Description @

B-=-=-F-BE-BF+-E-n

Open specification after create

9. Uncheck Open specification after create and click OK to continue.

10. Repeat the steps to create the pool Bidder, Manufacturer and Supplier.

https://lwww.visual-paradigm.com/tutorials/businessprocessmodeling.jsp

Page 3 of 13



Visual Paradigm Tutorial
How to Draw BPMN 2.0 Business Process Diagram?

11. Right-click on the Sales model and select Sub Diagrams > New Diagram... from the popup
menu.

w T Tutorial

¥ Elements (4)

Model Element » | Bidder 3 Customer
ﬁ Open 5ales Specification...
Rename...
Show Link...
Show View...
Stereotypes 3
| Sub Diagrams 4 ! I_Md
BE NewModel | New Diagram...
- Madel Trnsitor Existing Diagrams...
-E Transit From 3
E} Transit To 3

12. Inthe New Diagram window, select Business Process Diagram and click Next. Keep the
diagram name as provided and click OK to create the diagram.

called "Brainstorm™. When the meefing ends, you can organize the notes
and derive a diagram from them.

Business Process Diagram S

Model business workflow with the use of OMG BPMN (Business Process Model
and Notation).

Chart Diagram
Define the relationships between model elements in project.

Class Diagram

Design object model, persistence model for Hibernate ORM and REST API
with classes, their attributes, operations and inter-relationship.

Communication Diagram

Model the relationships between objects. Communication Diagram focuses
on teling whether a relationship exists between objects. It does not tell their
order and how objects interact with each other. v

| Next || concel |
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13. We can now start creating the business process diagram. First, let's create a start event. Select

the Start Event tool from the diagram toolbar, and then click on the empty area of the business
process diagram.

Sales Sales

<Unspedfied» | o

r-'io

SOO00FHD" M

14. Now click on the start event and drag out the Resource Catalog icon.
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15. Release the mouse button on the blank area of the diagram, and select Choreography Task
from Resource Catalog.
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16. Enter Order Request as the name of the choreogrpahy task and press Enter to confirm.
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17. Right-click on Order Request and select Open Specification...
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18. Select Customer pool as Participant 1.

[ References | Project Management | quaity | comments E8
ues Constraints Diagrams I Traceability
General Procedures Message Flows Stereotypes ‘
MName: |Order Request |
D: |ePos |
Participant 1: <Unspecified > W
Participant 2: <Unspecified>
[ Bidder

Initiating particdpant:
Loop type:

Description:

1 Manufacturer

[ Supplier

19. Select Manufacturer pool as Participant 2.

20. Select Customer pool as the Initiating participant.

References Project Management | quaity | comments =
ues Constraints | Diagrams I Traceability

General Procedures | Message Flows Stereotypes ‘
Name: |Order Request |
D: |ePos |
Participant 1: |= Customer W |
Participant 2: |E Manufacturer W |
Initiating participant: |1=| Customer - Sales W |
Loop type: | <Unspecified> w |
Description:

21. Click OK to confirm. Now the task Order Request is done. You can see that the initiating
participant is showing in the same color of the task, with the non-initiating participant showing in

gray.
( Customer )
O—bomﬂsmm
\ Manufacturer /

https://lwww.visual-paradigm.com/tutorials/businessprocessmodeling.jsp Page 6 of 13



Visual Paradigm Tutorial
How to Draw BPMN 2.0 Business Process Diagram?

22. Let's create a message between Customer and Manufacturer. Click on the Order Request task
and drag out the Resource Catalog icon.

*.
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23. Release the mouse button above the choreography task and select Message from Resource
Catalog.

== CO® O
@ R

o

Message

24. Then, select New Message Flow from "Customer" to "Manufacturer” from the popup menu.

Select Message Flow

Mew Message Flow from "Customer” to "Manufacturer”

s

Mew Message Flow from "Manufacturer” to "Customer”
l(_(.;IJSEBI'I'I-GI'

O—D Order Regue st

\ Manufacturer /

25. Enter Order as the name of message and then press Enter to confirm.

Order

£ ; A}
Customer

O—b Order Reque st

‘\_Manufacturer /
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26. Create an Event-based Exclusive Gateway from Order Request. Again, click on Order
Request and then drag out the Resource Catalog icon. Release the mouse button in the empty
space of the diagram and select Gateway from Resource Catalog to create a gateway.

]

Order

f ; Y
Customer

O—DOrdchcqucst — E
= &) O
O Okg B =

\Manufacturer /

Gateway

27. Enter Can Fulfill Order? as the name of gateway and press Enter to confirm. You can insert a

line break by pressing Alt + Enter.

O—b Order Reque st

Order

i ; A
Customer

\Manufacturer Can Fulfil

Onder?

28. Right-click on the gateway and select Type > Event-Based Exclusive Decision/Merge (XOR).

Ran
Ordey

a Open Specification...

Stereotypes

Model Element Properties

Type
Form Separate Diagram Sub-Process
Form Same Diagram Sub-Process
Edit
& Cut

Copy

Delete

Enter

4606000

<Unspecified»

Data-Based Exclusive Decision/Merge (XOR)

Event-Based Exclusive Decision/Merge (XOR) %

Inclusive Decision/Merge (OR)
Complex Decision/Merge

Parallel Fork/Join (AND)
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29. Repeat the steps to complete the business process diagram, like this:
( Customer [ Customer )
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: \_Manufacturer )/ \_Manufacturer /
[ Custlnmer ) ( Customer
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Parts must No
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Available?
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Me Part Auction
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Obtained?
30. There could be multiple instances of 'procure parts' activity running simultaneously. Let's
represent this by setting the loop type of task Procure Parts to Multi-Instance Loop. Right-click
on the Procure Parts task and select Open specification... from the popup menu.
31. Select Multi-Instance Loop for Loop type combo box.
¢ Choreography Task Specification “
References Project Management Quality Comments =f
Taooed Values Constraints Diagrams Traceability .
General Procedures Message Flows Stereotypes FE'
MName: Procure Parts
D: BP21
Participant 1: 1 Manufacturer W
Participant 2: 1 Supplier W
Initiating participant: | 3 Manufacturer - Sales W
Loop type: <Unspecified> w
Description: <Unspedified >

Standard Loop

32. Click OK to confirm. Now the Multi-Instance loop marker is shown in the Procure Parts task.

( Manufacturer )
Procure Parts |
1]
\__ Supplier /
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33. Let's create messages between Manufacturer and Bidder on the Part Auction task. With the use
of Resource Catalog, create a Message from the Part Auction activity. Select New Message
Flow from "Manufacturer" to "Bidder" from the popup menu.

~ Customer (_ Customer )
Order P Deliver Order
Order Confiation
: \Manufacturer / \Manufacturer }
I ( Customer )
( Customer Customer
No - Order
O—D Order Reque st - Rejection
g Can Fulfil Manufacturer
Order?
( Manufacturer ) ]
Capacity OK, Procure Parts - -
Parts must 11 == — No
be ordered \__Supplier / All Parts t Mes=ge
Available? Mew Message Flow from "Manufacturer” to "Bidder"
ﬂ Mew Message Flow from "Bidder” to "Manufacturer”
Mo Part Auction
Bitikn All Parts

34. Name the message as Part Request.

Obtained?

35. Repeat the step to create another message to Part Auction task. This time, select New
Message Flow from "Bidder" to "Manufacturer" during creation. Name the message as Part
Response. You can see that the message from Bidder to Manufacturer is in different color since
Bidder is non-initiating participant.

Part Request

[ Manufacturer )

]

Part Auction ——
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36. Now the gateway All Parts Available? and All Parts Obtained? in business process diagram only
modeled the false situation. What about the true case? Assuming that the flow should flow back
to the Order Confirmation task. We don't want to make the diagram too complicated by having
too many connector lines. Let's represent the flow with the use of a pair of intermediate events.
Click on the All Parts Available? gateway and drag out the Resource Catalog icon. Release the
mouse button above the gateway and select Intermediate Event from Resource Catalog. Enter
A as name and press Enter.
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37. Name the connector Yes.
38. Right-click on the intermediate event and select Trigger > Link Trigger.

39. Repeat the steps to create another link event from All Parts Obtained? gateway.
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40. Select Link Intermediate Event from the diagram toolbar.

™]

@ Cancel Intermediate Event

@ Compensation Intermediate Event
@ Conditional Intermediate Event
@ Link Intermediate Event

R IR 0] © [ORC)

@ Signal Intermediate Event
@ Multiple Intermediate Event

@ Parallel Multiple Intermediate Event

Cierdor
@ Message Intermediate Event
@ Timer Intermediate Event
@ Error Intermediate Event Z
@ Escalation Intermediate Event -
E

0680

41.

task. Up to now your diagram should look like this:

Tutorial

Click on the left hand side of the Order Confirmation task and name it A. Connect it with the

@_’f Customer (" Customer )
Iil A Order. P Deliver Order
Order Confimation
: \_Manufacturer )/ \Manufacturer /
[ Customer ( Customer )
No Order
Order R st L
O_' er Reque “| Rejection
T e Can Fulfil Manufacturer
Onder?
( Manufacturer
Capacity OK, Procure Parts
Parts must 11 No
be ordered \__Supplier ) Al Parts Part Request
Available? .
( Manufacturer
Mo Part Auction
\__Bidder )/ Al Parts A
! Obtained?

Part Response

https://lwww.visual-paradigm.com/tutorials/businessprocessmodeling.jsp

Page 12 of 13



Visual Paradigm Tutorial
How to Draw BPMN 2.0 Business Process Diagram?

42. Create the other messages. Finally, your business process diagram should look like this:
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Resources
1. Complete Project - Tutorial.vpp

Related Links
. Introduction to BPMN

. How to Define Working Procedures for Business Tasks
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